urllib3 (1.25.1) or chardet (3.0.4) doesn’t match a supported version

问题描述

安装nni时出现警告requests 2.21.0 has requirement urllib3<1.25,>=1.21.1, but you'll have urllib3 1.25.11 which is incompatible. 并且在执行nnictl时出现urllib3 (1.25.1) or chardet (3.0.4) doesn't match a supported version警告。

解决方法

I fixed the issue by manually updating the requests package using pip:
pip install --upgrade requests
Note that you may have to run this as root (sudo) depending on your Python installation, but be wary that doing so may or may not break other things relying on a different version of the package. If you are on a multi-user system, consider trying the --user parameter first.
The chardet package is now on version 3.0.4 and urllib3 is on 1.24.2.

留下评论